Diagnosing a Super Nintendo with Video Issues... and a PSA About Aftermarket Cables

May 19, 2021

This article will be more of a story and a PSA rather than a guide/help page. I had this SNES I was asked to fix. According to the owner, there was video output. This console had me scratching my head for quite a while before finding out the issue was rather simple. Let me take you through the whole process.

Below is a video that shows what the system acted like when I first tested it out. When hooked up to my Sony PVM, you can see a picture and hear sound, but it's completely messed up and loses sync after a while and only keeps getting worse. After turning the console off, I would see a white flash one the monitor, which gradually turned to black. Turning it back on after that would result in the same thing you can see in the video.

Replacing the capacitors

The issues the video signal had just reeked of capacitor issues to me. So, I ordered a set of capacitors and got to work replacing all capacitors in the system. I won't go into detail on how to do this in this article as it isn't the main point. However, I might write a separate article about this down the line.

Replacing the caps ended up making no difference at all. I was very surprised by this. Replacing the capacitors is never a bad thing, since it significantly extends the lifetime of the system. However, I had to investigate further...

Discovering the issue

After the capacitors didn't make a difference, I investigated further. Despite looking for any issues with the board I could think of, I just could not find any. After all this, I decided to try out a different cable. I didn't think this would make a difference, since I was testing with a known-working aftermarket cable that I use with my Super Famicom. I hooked the console up through a PAL RGB cable and... it actually worked perfectly! At this point I thought that it was only the composite signal that was not working. So I grabbed my official PAL Nintendo AV cable from my N64 and to my surprise, this also worked perfectly fine!

So turns out, the console was fine all along, and it's an issue with the aftermarket cable I was using. The owner of the system was very likely using the exact same cable type.

The issue with aftermarket Nintendo AV cables on PAL consoles

So what I've learned from all this, is that there is a fundamental difference between Nintendo's PAL AV cables, and their NTSC AV cables. (PAL being used mainly in Europe and Australia, and NTSC mostly found in the US and Japan.) The PAL cables have different components inside of them than NTSC cables, causing them to be incompatible with each other. I did not know about this and looking around online it seems to not be very well documented either.

The issue with cheap aftermarket Nintendo composite video cables, is that they are pretty much all design for NTSC systems and thus will behave weirdly with PAL systems. If you're looking for aftermarket cables for your PAL SNES, I highly suggest using RGB SCART cables that are specifically made for PAL systems, which can be easily found online. If you want to use composite video on your PAL SNES, I highly suggest going with an official Nintendo cable.